Processing Images from the SeeStar S50

From the YouTube Video “AMAZING images with the SeeStar SMART TELESCOPE”
by Cuiv, The Lazy Geek https://www.youtube.com/watch?v=IMoSAHOgbD4

He uses the following free software:

(1) GraXpert:  https://www.graxpert.com/ (processes the image at the very start, can crop
the image, remove background gradients such as light pollution and moon interference,
remove noise)

(2) Siril: ~ https://siril.org/ (64 bit. Used for general processing, colour calibration,
“stretching” using curves, adjust colour saturation)

(3) Gimp:  https://www.gimp.org/  (general purpose software like PhotoShop but free.
Optional but allows for more curve adjustments, sharpness

(4) Siril Seestar Script Tutorial:  https://siril.org/tutorials/seestar/  (I’'m not sure you have
to download this Script anymore)

Before downloading from the SeeStar S50:

If you plan on processing your images after a photo session, make sure when your SeeStar
is on that, in “Adjustments”, “Save Each Frame in Enhancing” is turned on.

And when you have your object in view, make sure it is in focus—the “Automatic focus”
doesn’t always give you the best focusing. You can use the up and down focus arrow keys.

To download images from the SeeStar, connect your computer to the SeeStar and you’ll find a
file called “My Works”. In it will be all the files from your session, both the 10 second individual
frames and the Stacked version that SeeStar has made from all of the frames .

For instance, if you’ve taken pictures of M51, you'll find two sets of folders:
(1) M51: this folder contains the stacked image of M51 done by the SeeStar itself. There will be
three files inside the folder: the .fits stacked RAW file, the final stacked image as a JPEG, and a
JPEG thumbnail)
(2) M51_sub: this folder contains all the 10 second .fits subframes used to build that final
image.

You can choose to process either (a) the already stacked .fits file that the SeeStar has done
itself, found in the folder M51 (this will be the short quick method) or (b) you can stack and
process all the .fits files yourself that are found in the M51_sub folder (this method is a slightly
longer, more involved process). You can compare for yourself which processing method gives
you the best results: the JPEG that the SeeStar has done, a JPEG from the short quick method,
or a JPEG from the more involved process.

The quick and easy method: found at 15:00 Minutes in the video
We will be processing the SeeStar fully stacked image found in the M__file that you have
downloaded from Siril ( e.g. the M51 file or NC__ or Gal___ or whatever).

Our Work flow will be  GraXpert, then Siril, then GIMP

Open GraXpert and click on the Advanced Tab on the extreme right and, under Background
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Extraction, select 1.0.1 and, under Denoise, select 2. (That should prompt the software to
download its Al model.)
(I find you have to give GraXpert time to load -- wait before you open the file or it might crash.)
Use steps on left side:
(1) Download the .fits file from the M51 file and Open it. It may open rather black with few
stars—this is because it is showing the RAW data and is the “unstretched” (or linear) image. If it
hasn’t automatically opened as “15% Bg, 3 sigma” you use the slider at the bottom to set it to
that. “No stretch” will be black.
(2) Crop (make sure you get rid of any artifacts due to the stacking/field rotation at the corners
but make sure you include plenty of stars in the image which is important later in Siril)
(3) Use Background Extrapolation to get rid of gradients/light pollution—make sure it is set to
“A1” —and use smoothness probably around “1”

Press Calculate Background (if you are not happy, you can try another smoothness level)
(4) Denoise to get rid of background noise but retaining detail (try a level of 0.7 or 0.6 and
move it around to get best results) (you can preview with and without your settings by clicking
on the arrow above the view box and clicking “gradient improved” on and off with “denoised”).
(6) Save Button: Save as a 32 bit file and as the “processed file”. *****Make sure you save it
with a .Fits extension, not .tif extension*** . You will then find this saved in the original M51
fileasa .fit file with a Graxpert name attached.

22:40 minutes into the video

Open Siril 1.2.3 Click on Open, (not home) and navigate to the .fits file in the M51 folder that
has the Graxpert name attached. Double-click on it.

(1) When you open the file, you won’t see much because it is the “unstretched” version. Just as
in Graxpert, you go down to the Drop Down at the bottom (may say “linear”) and choose
“AutoStretch”.

(2) Go to the top left bar and choose “Image Processing”. In the drop down menu, choose
Colour Calibration then > Photometric Colour Calibration (use the following values in the box if
not already entered: Focal length 250, pixel size 2.90, resolution 2.373). You input the
Metadata by typing in at the top the image name that you are processing (e.g. M51), click
“Find” and the correct co-ordinates will appear. Click on “Force Plate Holding”. You could also
click on “Flip image if needed.” Click “OK”. Close the box. (You need plenty of stars here for this
stage to be successful.)

(Here, if your image has a green tinge, you could click on Image Processing > Remove green
noise and click “apply”.

(3) Next we'’re going to “Stretch”. ***Down below, change the stretch from 15% back to
Linear ****

Go to Image Processing on top bar, then Histogram transformation. The triangle in the middle
moved to the left will “stretch” the curve to the right; the triangle on the far left when moved
to the base of the curve will darken the image. When you’ve adjusted it, click Apply. You can
repeat a number of times—try to keep the colours in the curve overlapping. You can expand
the view by clicking on the “+” sign. Or as an alternative to the above you can click on
“Automatic”.

(4) Next Image Processing > Colour Saturation and adjust. The “amount” slider increases the
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colour saturation—you can click on and off the preview button to see what your adjustments
have done. By increasing the “background factor” you can prevent your saturation level to
affect the background stars (can also preview on and off).

(5) Next Image Processing > Noise Reduction. Click on “Reduce salt and pepper noise”, adjust
and then click apply. If you are not happy, click on the “Undo” button on the top task bar and
readjust.

(6) Save by clicking on the arrow beside the save button on the top right. Change the name of
the file (e.g. by adding _siril to the file name e.g such as M51Graxpertsiril and make sure it is a
.tif format) . Click Save.

32:00 Minutes

GIMP

In GIMP, go to “Open” top left and navigate to the previous _siril.tif file and open it in GIMP.
We do 2 things in GIMP:

(1) Colours > Curves. This is a pure Contrast adjustment. Right-click to put a dot on the left,
middle and right parts of the line and adjust each a bit up and down to get desired contrast.
Click apply.

(2) Sharpening. Go to Filters > Enhance > Sharpen (Unsharp Mask). Use before and after
button and adjust.

Then to ***Export as a .JPG ***s0 it can be shared with others, go to File > Export As.... And
change the file extension to .jpg and click apply. (This may take time to appear in your folder).

An Alternate method of processing in which you line up and stack the images

yourself rather than have it done by the SeeStar.
This begins around Minute 35:35 in the video.

The work flow here will be  Siril > GraXpert > Siril > Gimp

Siril: Open Siril and click on “Conversion” tab in the top tool bar and then click on the “+” icon.
Then navigate to your folder that contains the _sub files (e.g. M51_sub). Open it and sort the
files by clicking on “type”. You want to Select and Copy just the .fits files (Shift + C). Select
them and click Add.

Next you create a folder where Siril does its processing. Go to the Home icon (not “Open”) top
left on tool bar, navigate to the _sub folder where you got the .fits files and click on Create a
new folder (icon on the top right “create a folder”), click on it, call it “Processing” and then
click on “Open”.

(1) In the Destination tab in Siril where it says “sequence name” at bottom of .fits file list, type
in the file name you are processing e.g M51-sub and then make sure Bayer option is checked.
Then click on Convert.

(2) You can then go to the Sequence tab, you'll see that e.g. M51_sub is listed (the name of the
sequence with the file extension). Click on Open Frame List and you’ll get a list of the files.
Double-click on the first image. You can click on “Auto-stretch” down below. The image will
appear green. Click on the Chain icon beside the stretch icon and the picture will show the



image with red-green-blue aligned. Go back to first image and then press X to close the file.

(3) Next, click on Registration (registration aligns all the images). Click on Registration Method
and choose “Two Pass Global Star Alignment” and then set Minimum Star Pairs to 4. Click on
the little gear icon beside the Minimum Star Pairs and when it opens leave everything to
default but click on the icon that has the stars with circles. Click Apply. You’ll see that a
number of stars have been detected—you want 25 or more stars. If you don’t have any stars or
less than 25, click on Relax the PSS checks and reduce the Threshold to 0.5 and then re-click on
the Circled stars icon. (Zoom in on the image to make sure you are using stars, not noise). Once
you are happy, close that box and click on Go Register. When it finishes registering you will see
how many of your images were used and how many were rejected.

(4) Go back to the Registration Method tab under Automatic image registration and click on
“Apply Existing Registration.” Set framing method to Maximum, keep everything else the
same and click on Go Register. (To double-check your work you could go back to the Sequence
tab and Open Frame list and click on the various files and you can see how the images have
been rotated to align.)

(5)The last step is stacking. Go to the Stacking tab, click on Stacking Method as Average
Stacking with Rejection, Normalization to be Additive with Scaling, Pixel Rejection as
Winserized Sigma Clipping, under Weighting tab choose Number of Stars. Then click on Start
Stacking.

(6) Once finished you can save it (top bar with an arrow pointing down) (It will appear in the top
leftasa r_Mwhateverstacked.fit name (make sure itis in the .fit format and not .tif) and it
will be in your Mwhatever_sub folder. (It can be named whatever you want e.g
M51long_sub but must have the .fits extension.)

Now you have aligned and stacked the files and have a .fits file that should be similar to the .fits
file that the SeeStar produced. From here on you just repeat the steps you did in the “quick and
easy method” i.e. GraXert > Siril > GIMP. When you are in Siril, you don’t have to do the
registration and stacking steps because that has already been done.
For example (at 46:00 Minutes in the Video:
GraXpert: Open GraXpert, load in the Stacked image, and you can see the image fully stacked
with 15 % stretching

Crop to avoid any artifacts, apply

Background Extraction (try 0.5 setting) to get rid of any gradients

Then Denoise (e.g. 0.7 setting)

Save (Could save as the same name) (it will have GraXpert as part of the name)

In Siril,
(1) open the image (you may have to search in your folder at the end of your other .fits files and
before your JPG images)

Auto-Stretch on,
(2) Image processing > Photometric Colour calibration (could use the default options) or do the
Forced plate folding, reduce threshold, relax
(3) Go back to Linear (disable autostretch) and do image processing > Histogram
Transformation. Click on the right “hand” and move left to brighten and/or move left hand to
base of curve to darken background. Click apply. (Or instead click “auto”). Can repeat a couple
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of times (but noise increases)

(4) Then go to Image Processing> Colour Saturation and play with the colour slider and
background slider and Apply. Could repeat

(5)Could do another Image Processing> Noise Reduction. Could start with modulation of 0.4 to
start. Click off and on to check with and without, change levels to get what you want and then
“Apply”

(6) Then Save as a “.tif” file (can be opened in GIMP or in PhotoShop)

51:00 Minutes (GIMP)
Open image in GIMP and we can play with Colours > Curves as before

Filter > Unsharp Mask. (Maybe reduce radius,
reduce amount)
Then save and ***export*** (not Save or Save As...) as a JPEG file. Look into the possible
extensions and click on

Compare the three images: the one from the SeeStar, the one Stacked by SeeStar, and the one
processed by ourselves.



